summaryrefslogtreecommitdiff
path: root/app/fonttosfnt/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/fonttosfnt/configure.ac')
-rw-r--r--app/fonttosfnt/configure.ac28
1 files changed, 16 insertions, 12 deletions
diff --git a/app/fonttosfnt/configure.ac b/app/fonttosfnt/configure.ac
index 0782b0351..d5e9610cb 100644
--- a/app/fonttosfnt/configure.ac
+++ b/app/fonttosfnt/configure.ac
@@ -21,15 +21,20 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(fonttosfnt,[1.0.4], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],fonttosfnt)
-AM_INIT_AUTOMAKE([dist-bzip2])
-AM_MAINTAINER_MODE
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT(fonttosfnt,[1.0.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],fonttosfnt)
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
-AM_CONFIG_HEADER(config.h)
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
-AC_PROG_CC
-AC_PROG_INSTALL
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
AC_CHECK_FUNC(setenv, have_setenv=yes, have_setenv=no)
AC_CHECK_FUNCS([vasprintf])
@@ -42,10 +47,9 @@ AM_CONDITIONAL(NEED_SETENV, [test x$have_setenv = xno])
# Checks for pkg-config packages
PKG_CHECK_MODULES(FONTTOSFNT, xproto freetype2 fontenc)
-AC_SUBST(FONTTOSFNT_CFLAGS)
-AC_SUBST(FONTTOSFNT_LIBS)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT