summaryrefslogtreecommitdiff
path: root/app/luit/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/luit/configure.ac')
-rw-r--r--app/luit/configure.ac66
1 files changed, 48 insertions, 18 deletions
diff --git a/app/luit/configure.ac b/app/luit/configure.ac
index 752618236..c214d85c9 100644
--- a/app/luit/configure.ac
+++ b/app/luit/configure.ac
@@ -1,4 +1,3 @@
-
dnl Copyright 2005 Red Hat, Inc.
dnl
dnl Permission to use, copy, modify, distribute, and sell this software and its
@@ -21,25 +20,28 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(luit,[1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],luit)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([luit], [1.1.1],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [luit])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
+AC_CONFIG_HEADERS([config.h])
-AC_PROG_CC
-AC_PROG_INSTALL
AC_CANONICAL_HOST
-AC_CHECK_LIB(z, gzopen,, AC_MSG_ERROR([zlib not found]))
-# Check for openpty() in -lutil if the UNIX98-style pty functions are not
-# available. E.g. for GNU libc 2.0.
-AC_CHECK_FUNCS(grantpt, [], AC_CHECK_LIB(util,openpty))
+AC_CHECK_HEADERS([pty.h stropts.h sys/param.h sys/select.h])
+AC_CHECK_FUNCS([select grantpt posix_openpt])
AC_ARG_WITH(localealiasfile,
- AC_HELP_STRING([--with-localealiasfile=<path>],
+ AS_HELP_STRING([--with-localealiasfile=<path>],
[The locale alias file (default: ${datadir}/X11/locale/locale.alias)]),
[LOCALEALIASFILE="$withval"],
[LOCALEALIASFILE=${datadir}/X11/locale/locale.alias])
@@ -48,20 +50,48 @@ AC_SUBST([LOCALEALIASFILE])
# Checks for pkg-config packages
PKG_CHECK_MODULES(LUIT, fontenc)
+# We don't link against libX11, just use its locale.alias data file
+PKG_CHECK_EXISTS(x11, [],
+ [AC_MSG_WARN([libX11 not found. luit may not be able to find locale aliases without it.])])
+
case $host_os in
+ # darwin has poll() but can't be used to poll character devices (atleast through SnowLeopard)
+ darwin*)
+ OS_CFLAGS=
+ ;;
linux*)
+ AC_CHECK_HEADERS([poll.h])
+ AC_CHECK_FUNCS([poll])
OS_CFLAGS="-D_XOPEN_SOURCE=500"
;;
*)
+ AC_CHECK_HEADERS([poll.h])
+ AC_CHECK_FUNCS([poll])
OS_CFLAGS=
;;
esac
+AC_SUBST(OS_CFLAGS)
+
+AC_CHECK_HEADERS([pty.h stropts.h sys/ioctl.h sys/param.h sys/poll.h sys/select.h sys/time.h termios.h])
+AC_CHECK_FUNCS([grantpt putenv select strdup])
+
+if test "x$ac_cv_func_grantpt" != "xyes" ; then
+ AC_CHECK_LIB(util, openpty, [cf_have_openpty=yes],[cf_have_openpty=no])
+ if test "$cf_have_openpty" = yes ; then
+ LIBS="-lutil $LIBS"
+ AC_DEFINE(HAVE_OPENPTY, 1, [Have openpty in libutil])
+ AC_CHECK_HEADERS( \
+ util.h \
+ libutil.h \
+ pty.h \
+ )
+ fi
+fi
-LUIT_CFLAGS="$LUIT_CFLAGS $OS_CFLAGS"
-AC_SUBST(LUIT_CFLAGS)
-AC_SUBST(LUIT_LIBS)
+CF_FUNC_POLL
+CF_SIGWINCH
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
+AC_CONFIG_FILES([Makefile
+ man/Makefile])
-AC_OUTPUT([Makefile])
+AC_OUTPUT