summaryrefslogtreecommitdiff
path: root/app/x11perf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'app/x11perf/Makefile.am')
-rw-r--r--app/x11perf/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/app/x11perf/Makefile.am b/app/x11perf/Makefile.am
index d6359099e..b8205452f 100644
--- a/app/x11perf/Makefile.am
+++ b/app/x11perf/Makefile.am
@@ -96,3 +96,13 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog