summaryrefslogtreecommitdiff
path: root/app/xcompmgr/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xcompmgr/configure.ac')
-rw-r--r--app/xcompmgr/configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/app/xcompmgr/configure.ac b/app/xcompmgr/configure.ac
index aa0a897ac..12a169211 100644
--- a/app/xcompmgr/configure.ac
+++ b/app/xcompmgr/configure.ac
@@ -2,14 +2,21 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.57)
-AC_INIT([xcompmgr], [1.1.4], [xorg@freedesktop.org])
+AC_INIT([xcompmgr], [1.1.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
AC_CONFIG_SRCDIR([xcompmgr.c])
AM_INIT_AUTOMAKE([dist-bzip2 foreign])
AM_MAINTAINER_MODE
+
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+
AC_CONFIG_HEADER([config.h])
# Checks for programs.
AC_PROG_CC
+XORG_DEFAULT_OPTIONS
# Checks for header files.
AC_HEADER_STDC
@@ -24,6 +31,7 @@ AC_FUNC_MALLOC
AC_CHECK_FUNCS([gettimeofday localtime_r])
PKG_CHECK_MODULES(XCOMPMGR, xcomposite xfixes xdamage xrender)
+AC_SUBST(XCOMPMGR_CFLAGS)
+AC_SUBST(XCOMPMGR_LIBS)
-AC_CONFIG_FILES([Makefile])
-AC_OUTPUT
+AC_OUTPUT([Makefile])