summaryrefslogtreecommitdiff
path: root/app/xdm/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xdm/configure.ac')
-rw-r--r--app/xdm/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/app/xdm/configure.ac b/app/xdm/configure.ac
index dc5ba7de1..aed600202 100644
--- a/app/xdm/configure.ac
+++ b/app/xdm/configure.ac
@@ -182,6 +182,16 @@ AC_SUBST(RANDOMMANDEFS)
# turned off everywhere but on OpenBSD.
AM_CONDITIONAL(HAS_KERBEROS_FIVE, false)
+#
+# Privsep
+#
+AC_ARG_ENABLE(privsep,
+ AC_HELP_STRING([--enable-privsep],
+ [Build support for X server privilege separation (default is NO)]),
+ [ENABLE_PRIVSEP="$enableval"], [ENABLE_PRIVSEP="no"])
+if test x$ENABLE_PRIVSEP = xyes ; then
+ AC_DEFINE(X_PRIVSEP, 1, [Use X server privilege separation])
+fi
# Figure out where everything goes in the filesystem