summaryrefslogtreecommitdiff
path: root/app/xeyes/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xeyes/configure.ac')
-rw-r--r--app/xeyes/configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/app/xeyes/configure.ac b/app/xeyes/configure.ac
index a8c4c6a72..6635b9e8e 100644
--- a/app/xeyes/configure.ac
+++ b/app/xeyes/configure.ac
@@ -23,8 +23,8 @@ dnl Process this file with autoconf to create configure.
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xeyes], [1.1.2],
- [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xeyes])
+AC_INIT([xeyes], [1.2.0],
+ [https://gitlab.freedesktop.org/xorg/app/xeyes/issues], [xeyes])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
@@ -39,7 +39,7 @@ XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XEYES, [x11 xt xext xmu xproto >= 7.0.17])
+PKG_CHECK_MODULES(XEYES, [xi >= 1.7 x11 xt xext xmu xproto >= 7.0.17])
dnl Optional dependencies
AC_ARG_WITH(xrender, AS_HELP_STRING([--with-xrender],[Use Xrender for rendering (Default is YES)]),use_xrender="$withval",use_xrender="try")
@@ -48,6 +48,12 @@ if test x$use_xrender != xno ; then
AC_DEFINE([XRENDER],1,[Define to use X Render Extension])
fi
+AC_ARG_WITH(present, AS_HELP_STRING([--with-present],[Use Present for updates (Default is AUTO)]),use_present="$withval",use_present="try")
+if test x$use_present != xno ; then
+ PKG_CHECK_MODULES(PRESENT, [x11-xcb xcb-present >= 1.9 xcb-xfixes xcb-damage])
+ AC_DEFINE([PRESENT],1,[Define to use X Present Extension])
+fi
+
AC_CONFIG_FILES([
Makefile
man/Makefile])