summaryrefslogtreecommitdiff
path: root/app/xgc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xgc/configure.ac')
-rw-r--r--app/xgc/configure.ac21
1 files changed, 13 insertions, 8 deletions
diff --git a/app/xgc/configure.ac b/app/xgc/configure.ac
index 40f728ae9..8c1bbbd5f 100644
--- a/app/xgc/configure.ac
+++ b/app/xgc/configure.ac
@@ -22,27 +22,32 @@ dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ([2.57])
-AC_INIT(xgc,[1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xgc)
+AC_INIT(xgc, [1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xgc)
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-
AM_CONFIG_HEADER(config.h)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
+XORG_DEFAULT_OPTIONS
+
AC_PROG_LEX
AC_PROG_YACC
AC_PROG_CC
AC_PROG_INSTALL
-XAW_CHECK_XPRINT_SUPPORT(XGC)
-
+PKG_CHECK_MODULES(XGC, xaw7)
AC_SUBST(XGC_CFLAGS)
AC_SUBST(XGC_LIBS)
PKG_CHECK_MODULES(APPDEFS, xt)
-appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+AC_ARG_WITH(appdefaultdir,
+ AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ [specify directory for app-defaults files (default is autodetected)]),
+ [appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-
AC_OUTPUT([Makefile])