summaryrefslogtreecommitdiff
path: root/app/xgc/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xgc/configure.ac')
-rw-r--r--app/xgc/configure.ac22
1 files changed, 16 insertions, 6 deletions
diff --git a/app/xgc/configure.ac b/app/xgc/configure.ac
index 667a3e74f..04f55f6fc 100644
--- a/app/xgc/configure.ac
+++ b/app/xgc/configure.ac
@@ -20,12 +20,16 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([xgc], [1.0.3],
+AC_INIT([xgc], [1.0.4],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xgc])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-AM_CONFIG_HEADER(config.h)
# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
@@ -36,15 +40,21 @@ XORG_DEFAULT_OPTIONS
AC_PROG_LEX
AC_PROG_YACC
AC_PATH_PROG([YACC_INST], $YACC)
-AC_CHECK_FILE([$srcdir/gram.c], [],
- [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])])
+if test ! -f "gram.c"; then
+ if test -z "$YACC_INST"; then
+ AC_MSG_ERROR([yacc not found - unable to compile gram.y])
+ fi
+fi
PKG_CHECK_MODULES(XGC, xaw7 xt)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
AC_ARG_WITH(appdefaultdir,
- AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ AS_HELP_STRING([--with-appdefaultdir=<pathname>],
[specify directory for app-defaults files (default is autodetected)]),
[appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT