summaryrefslogtreecommitdiff
path: root/app/xmessage/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xmessage/configure.ac')
-rw-r--r--app/xmessage/configure.ac24
1 files changed, 16 insertions, 8 deletions
diff --git a/app/xmessage/configure.ac b/app/xmessage/configure.ac
index 588dc015b..e898cefaa 100644
--- a/app/xmessage/configure.ac
+++ b/app/xmessage/configure.ac
@@ -22,25 +22,33 @@ dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ([2.57])
-AC_INIT(xmessage,[1.0.1], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xmessage)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_INIT(xmessage, [1.0.3],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xmessage)
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.4 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.4)
+XORG_DEFAULT_OPTIONS
+
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
+
# Checks for pkg-config packages
-XAW_CHECK_XPRINT_SUPPORT(XMESSAGE)
-AC_SUBST(XMESSAGE_CFLAGS)
-AC_SUBST(XMESSAGE_LIBS)
+PKG_CHECK_MODULES(XMESSAGE, xaw7)
PKG_CHECK_MODULES(APPDEFS, xt)
-appdefaultdir=$(pkg-config --variable=appdefaultdir xt)
+xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
+AC_ARG_WITH(appdefaultdir,
+ AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ [specify directory for app-defaults files (default is autodetected)]),
+ [appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
AC_SUBST(appdefaultdir)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
AC_OUTPUT([Makefile])