summaryrefslogtreecommitdiff
path: root/app/xrandr/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xrandr/configure.ac')
-rw-r--r--app/xrandr/configure.ac18
1 files changed, 7 insertions, 11 deletions
diff --git a/app/xrandr/configure.ac b/app/xrandr/configure.ac
index 55c141be4..264dab129 100644
--- a/app/xrandr/configure.ac
+++ b/app/xrandr/configure.ac
@@ -20,27 +20,23 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xrandr,[1.3.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],xrandr)
+AC_PREREQ([2.60])
+AC_INIT([xrandr], [1.3.4],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xrandr])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.4 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.4)
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
AM_CONFIG_HEADER(config.h)
-AC_PROG_CC
-AC_PROG_INSTALL
-
AC_CHECK_LIB(m,floor)
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(XRANDR, xrandr >= 1.3 xrender x11)
-AC_SUBST(XRANDR_CFLAGS)
-AC_SUBST(XRANDR_LIBS)
-
AC_OUTPUT([Makefile])