summaryrefslogtreecommitdiff
path: root/app/xstdcmap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'app/xstdcmap/Makefile.am')
-rw-r--r--app/xstdcmap/Makefile.am40
1 files changed, 9 insertions, 31 deletions
diff --git a/app/xstdcmap/Makefile.am b/app/xstdcmap/Makefile.am
index 6a914e4e7..9987787d5 100644
--- a/app/xstdcmap/Makefile.am
+++ b/app/xstdcmap/Makefile.am
@@ -19,45 +19,23 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS = man
bin_PROGRAMS = xstdcmap
-xstdcmap_CFLAGS = $(XSTDCMAP_CFLAGS) -D_BSD_SOURCE
+AM_CFLAGS = $(XSTDCMAP_CFLAGS) -D_BSD_SOURCE $(CWARNFLAGS)
xstdcmap_LDADD = $(XSTDCMAP_LIBS)
xstdcmap_SOURCES = \
xstdcmap.c
-appman_PRE = \
- xstdcmap.man
+MAINTAINERCLEANFILES = ChangeLog INSTALL
+.PHONY: ChangeLog INSTALL
-appmandir = $(APP_MAN_DIR)
+INSTALL:
+ $(INSTALL_CMD)
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
+ChangeLog:
+ $(CHANGELOG_CMD)
-EXTRA_DIST = $(appman_PRE)
-CLEANFILES = $(appman_DATA)
-
-SED = sed
-
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
- XORGMANNAME = X Version 11
-
-MAN_SUBSTS = \
- -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
- -e 's|__xservername__|Xorg|g' \
- -e 's|__xconfigfile__|xorg.conf|g' \
- -e 's|__projectroot__|$(prefix)|g' \
- -e 's|__apploaddir__|$(appdefaultdir)|' \
- -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
- -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
- -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
- -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
- -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-.man.$(APP_MAN_SUFFIX):
- sed $(MAN_SUBSTS) < $< > $@
+dist-hook: ChangeLog INSTALL