summaryrefslogtreecommitdiff
path: root/app/xtrap/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'app/xtrap/Makefile.am')
-rw-r--r--app/xtrap/Makefile.am159
1 files changed, 159 insertions, 0 deletions
diff --git a/app/xtrap/Makefile.am b/app/xtrap/Makefile.am
new file mode 100644
index 000000000..030969a27
--- /dev/null
+++ b/app/xtrap/Makefile.am
@@ -0,0 +1,159 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+
+bin_PROGRAMS = \
+ xtrapchar \
+ xtrapproto \
+ xtrapin \
+ xtrapout \
+ xtrapstats \
+ xtrapreset \
+ xtrapinfo
+
+
+#
+# xtrapchar
+#
+xtrapchar_CFLAGS = $(XTRAP_APP_CFLAGS)
+xtrapchar_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapchar_SOURCES = \
+ xtrapchar.c \
+ chparse.c \
+ chparse.h \
+ XEKeybCtrl.c \
+ XEKeybCtrl.h
+
+#
+# xtrapin
+#
+xtrapin_CFLAGS = $(XTRAP_APP_CFLAGS) -D_BSD_SOURCE
+xtrapin_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapin_SOURCES = \
+ xtrapin.c \
+ XEKeybCtrl.c \
+ XEKeybCtrl.h
+
+#
+# xtrapout
+#
+xtrapout_CFLAGS = $(XTRAP_APP_CFLAGS) -D_BSD_SOURCE
+xtrapout_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapout_SOURCES = \
+ xtrapout.c \
+ XEKeybCtrl.c \
+ XEKeybCtrl.h
+
+#
+# xtrapproto
+#
+xtrapproto_CFLAGS = $(XTRAP_APP_CFLAGS)
+xtrapproto_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapproto_SOURCES = \
+ xtrapproto.c
+
+#
+# xtrapreset
+#
+xtrapreset_CFLAGS = $(XTRAP_APP_CFLAGS)
+xtrapreset_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapreset_SOURCES = \
+ xtrapreset.c
+
+#
+# xtrapstats
+#
+xtrapstats_CFLAGS = $(XTRAP_APP_CFLAGS)
+xtrapstats_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapstats_SOURCES = \
+ xtrapstats.c
+
+#
+# xtrapinfo
+#
+xtrapinfo_CFLAGS = $(XTRAP_APP_CFLAGS)
+xtrapinfo_LDADD = $(XTRAP_APP_LIBS)
+
+xtrapinfo_SOURCES = \
+ xtrapinfo.c \
+ XEKeybCtrl.c \
+ XEKeybCtrl.h
+
+appman_PRE = \
+ xtrap.man
+
+
+APP_MAN_DIR_SUFFIX = $(APP_MAN_DIR:@mandir@/man%=%)
+
+appmandir = $(APP_MAN_DIR)
+
+appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@) \
+ $(man_shadows:=.@APP_MAN_SUFFIX@)
+
+BUILT_SOURCES = shadows.DONE
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA) $(BUILT_SOURCES)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xorgversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|' \
+ -e 's|__xservername__|Xorg|g' \
+ -e 's|__xconfigfile__|xorg.conf|g' \
+ -e 's|__projectroot__|$(prefix)|g' \
+ -e 's|__apploaddir__|$(appdefaultdir)|' \
+ -e 's|__appmansuffix__|$(APP_MAN_SUFFIX)|g' \
+ -e 's|__libmansuffix__|$(LIB_MAN_SUFFIX)|g' \
+ -e 's|__adminmansuffix__|$(ADMIN_MAN_SUFFIX)|g' \
+ -e 's|__miscmansuffix__|$(MISC_MAN_SUFFIX)|g' \
+ -e 's|__filemansuffix__|$(FILE_MAN_SUFFIX)|g'
+
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@
+
+man_shadows = \
+ xtrapreset \
+ xtrapinfo \
+ xtrapstats \
+ xtrapout \
+ xtrapin \
+ xtrapchar \
+ xtrapproto
+
+shadows.DONE:
+ -rm -f $(man_shadows:=.@APP_MAN_SUFFIX@)
+ (for i in $(man_shadows:=.@APP_MAN_SUFFIX@) ; do \
+ echo .so man$(APP_MAN_DIR_SUFFIX)/xtrap.$(APP_MAN_SUFFIX) > $$i; \
+ done)