summaryrefslogtreecommitdiff
path: root/app/xvidtune/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xvidtune/configure.ac')
-rw-r--r--app/xvidtune/configure.ac28
1 files changed, 15 insertions, 13 deletions
diff --git a/app/xvidtune/configure.ac b/app/xvidtune/configure.ac
index 474f19a12..bef3a0c7f 100644
--- a/app/xvidtune/configure.ac
+++ b/app/xvidtune/configure.ac
@@ -21,31 +21,33 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xvidtune, [1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xvidtune)
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT(xvidtune, [1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xvidtune)
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.4 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.4)
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AM_CONFIG_HEADER(config.h)
-
-AC_PROG_CC
-AC_PROG_INSTALL
# Checks for pkg-config packages
PKG_CHECK_MODULES(XVIDTUNE, xxf86vm xt xaw7 xmu x11)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`
AC_ARG_WITH(appdefaultdir,
- AC_HELP_STRING([--with-appdefaultdir=<pathname>],
+ AS_HELP_STRING([--with-appdefaultdir=<pathname>],
[specify directory for app-defaults files (default is autodetected)]),
[appdefaultdir="$withval"], [appdefaultdir="${xt_appdefaultdir}"])
-AC_SUBST(XVIDTUNE_CFLAGS)
-AC_SUBST(XVIDTUNE_LIBS)
AC_SUBST(appdefaultdir)
-AC_OUTPUT([Makefile])
+AC_CONFIG_FILES([
+ Makefile
+ man/Makefile])
+AC_OUTPUT