summaryrefslogtreecommitdiff
path: root/lib/fontconfig/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/fontconfig/doc/Makefile.am')
-rw-r--r--lib/fontconfig/doc/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/lib/fontconfig/doc/Makefile.am b/lib/fontconfig/doc/Makefile.am
index d1311af5f..1ec8c0b3f 100644
--- a/lib/fontconfig/doc/Makefile.am
+++ b/lib/fontconfig/doc/Makefile.am
@@ -1,6 +1,4 @@
#
-# $Xorg: Makefile.am,v 1.1.1.1 2006/11/25 18:41:58 matthieu Exp $
-#
# Copyright © 2003 Keith Packard
#
# Permission to use, copy, modify, distribute, and sell this software and its
@@ -142,7 +140,7 @@ fontconfig-devel.txt: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml
fontconfig-devel.pdf: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
$(RM) $@
- ../missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+ $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
|| echo Failed to generate $@ >&2; \
(test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
@@ -160,7 +158,7 @@ fontconfig-user.txt: local-fontconfig-user.sgml version.sgml confdir.sgml
fontconfig-user.pdf: local-fontconfig-user.sgml version.sgml confdir.sgml
$(RM) $@
- ../missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+ $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
|| echo Failed to generate $@ >&2; \
(test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
@@ -170,7 +168,14 @@ confdir.sgml: ${DOC_SRC}/confdir.sgml.in
CLEANFILES=confdir.sgml local-fontconfig-user.sgml local-fontconfig-devel.sgml
+htmldoc_DATA = $(HTML_DIR)/*
+
+$(HTML_DIR)/*: $(HTML_DIR)
+
else
+
+htmldoc_DATA = $(srcdir)/$(HTML_DIR)/*
+
all-local:
clean-local:
endif
@@ -179,6 +184,3 @@ htmldocdir=$(docdir)/$(HTML_DIR)
doc_DATA = $(DOC_FILES)
-htmldoc_DATA = $(HTML_DIR)/*
-
-$(HTML_DIR)/*: $(HTML_DIR)