summaryrefslogtreecommitdiff
path: root/lib/fontconfig/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/fontconfig/src/Makefile.am')
-rw-r--r--lib/fontconfig/src/Makefile.am20
1 files changed, 17 insertions, 3 deletions
diff --git a/lib/fontconfig/src/Makefile.am b/lib/fontconfig/src/Makefile.am
index f18192293..d73b0dc41 100644
--- a/lib/fontconfig/src/Makefile.am
+++ b/lib/fontconfig/src/Makefile.am
@@ -1,6 +1,4 @@
#
-# $Xorg: Makefile.am,v 1.1.1.1 2006/11/25 18:42:23 matthieu Exp $
-#
# Copyright © 2003 Keith Packard
#
# Permission to use, copy, modify, distribute, and sell this software and its
@@ -25,6 +23,8 @@ if OS_WIN32
export_symbols = -export-symbols fontconfig.def
+fontconfig_def_dependency = fontconfig.def
+
# gcc import library install/uninstall
install-libtool-import-lib:
@@ -39,6 +39,8 @@ else
install-libtool-import-lib:
uninstall-libtool-import-lib:
+fontconfig_def_dependency =
+
endif
if MS_LIB_AVAILABLE
@@ -73,7 +75,7 @@ INCLUDES = \
-DFC_CACHEDIR='"$(FC_CACHEDIR)"' \
-DFONTCONFIG_PATH='"$(CONFDIR)"'
-EXTRA_DIST = fontconfig.def.in makealias
+EXTRA_DIST = makealias
noinst_HEADERS=fcint.h
@@ -112,6 +114,8 @@ libfontconfig_la_LDFLAGS = \
libfontconfig_la_LIBADD = $(ICONV_LIBS) $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS)
+libfontconfig_la_DEPENDENCIES = $(fontconfig_def_dependency)
+
install-data-local: install-ms-import-lib install-libtool-import-lib
uninstall-local: uninstall-ms-import-lib uninstall-libtool-import-lib
@@ -127,3 +131,13 @@ fcalias.h: $(top_srcdir)/src/makealias $(PUBLIC_FILES)
sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" $(PUBLIC_FILES)
CLEANFILES := $(ALIAS_FILES)
+
+fontconfig.def: $(PUBLIC_FILES)
+ echo Generating $@
+ (echo EXPORTS; \
+ (cat $(PUBLIC_FILES) || echo 'FcERROR ()' ) | \
+ grep '^Fc[^ ]* *(' | sed -e 's/ *(.*$$//' -e 's/^/ /' | \
+ sort; \
+ echo LIBRARY libfontconfig-@LT_CURRENT_MINUS_AGE@.dll; \
+ echo VERSION @LT_CURRENT@.@LT_REVISION@) >$@
+ @ ! grep -q FcERROR $@ || ($(RM) $@; false)