summaryrefslogtreecommitdiff
path: root/lib/libXcursor/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXcursor/man/Makefile.am')
-rw-r--r--lib/libXcursor/man/Makefile.am47
1 files changed, 40 insertions, 7 deletions
diff --git a/lib/libXcursor/man/Makefile.am b/lib/libXcursor/man/Makefile.am
index 725a67686..0be44447e 100644
--- a/lib/libXcursor/man/Makefile.am
+++ b/lib/libXcursor/man/Makefile.am
@@ -1,18 +1,51 @@
libmandir = $(LIB_MAN_DIR)
-libman_PRE = Xcursor.man
-libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
+libman_PRE = \
+ Xcursor.man \
+ $(Xcursor_shadows:=.man)
+
+Xcursor_shadows = \
+ XcursorImageCreate \
+ XcursorImageDestroy \
+ XcursorImagesCreate \
+ XcursorImagesDestroy \
+ XcursorCursorsCreate \
+ XcursorCursorsDestroy \
+ XcursorXcFileLoadImage \
+ XcursorXcFileLoadImages \
+ XcursorXcFileLoadAllImages \
+ XcursorXcFileLoad \
+ XcursorXcFileSave \
+ XcursorFilenameLoadImage \
+ XcursorFilenameLoadImages \
+ XcursorFilenameLoadAllImages \
+ XcursorFilenameLoad \
+ XcursorFilenameSaveImages \
+ XcursorFilenameSave \
+ XcursorLibraryLoadImage \
+ XcursorLibraryLoadImages \
+ XcursorFilenameLoadCursor \
+ XcursorLibraryLoadCursor \
+ XcursorLibraryLoadCursors \
+ XcursorShapeLoadImage \
+ XcursorShapeLoadImages \
+ XcursorShapeLoadCursor \
+ XcursorShapeLoadCursors \
+ XcursorSupportsARGB \
+ XcursorSetDefaultSize \
+ XcursorGetDefaultSize \
+ XcursorSetTheme \
+ XcursorGetTheme
-all-local: $(libman_DATA)
+libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
EXTRA_DIST = $(libman_PRE)
CLEANFILES = $(libman_DATA)
SUFFIXES = .$(LIB_MAN_SUFFIX) .man
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+MAN_SUBSTS += -e 's|__XCURSORPATH__|$(XCURSORPATH_LIST)|g'
.man.$(LIB_MAN_SUFFIX):
- -rm -f $@
- sed 's/__xorgversion__/"$(XORGRELSTRING)"/; s/__LIB_MAN_SUFFIX__/$(LIB_MAN_SUFFIX)/; s%__prefix__%$(prefix)%g; s%__ICONDIR__%$(ICONDIR)%g' < $< > $@
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@