summaryrefslogtreecommitdiff
path: root/lib/libXdamage/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXdamage/configure.ac')
-rw-r--r--lib/libXdamage/configure.ac57
1 files changed, 9 insertions, 48 deletions
diff --git a/lib/libXdamage/configure.ac b/lib/libXdamage/configure.ac
index 4390bd8e2..845023e70 100644
--- a/lib/libXdamage/configure.ac
+++ b/lib/libXdamage/configure.ac
@@ -1,6 +1,4 @@
dnl
-dnl $Id: configure.ac,v 1.1 2006/11/25 17:01:17 matthieu Exp $
-dnl
dnl Copyright © 2003 Keith Packard, Noah Levitt
dnl
dnl Permission to use, copy, modify, distribute, and sell this software and its
@@ -26,71 +24,34 @@ dnl Process this file with autoconf to create configure.
AC_PREREQ([2.57])
dnl
-dnl Version should match the current XFixes version. XFixesQueryVersion
-dnl returns the version from xfixeswire.h, NOT the version we set here. But we
+dnl Version should match the current XDamage version. XDamageQueryVersion
+dnl returns the version from damagewire.h, NOT the version we set here. But we
dnl try to keep these the same. Note that the library has an extra
dnl digit in the version number to track changes which don't affect the
-dnl protocol, so Xfixes version l.n.m corresponds to protocol version l.n
+dnl protocol, so Xdamage version l.n.m corresponds to protocol version l.n
dnl
-AC_INIT(libXdamage, 1.0.4, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXdamage)
+AC_INIT(libXdamage, 1.1.2, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXdamage)
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
-
-# Check for X
-PKG_CHECK_MODULES(X, x11,
- [x_found_with_pkgconfig=yes],
- [x_found_with_pkgconfig=no])
-
-if test "$x_found_with_pkgconfig" = "no"
-then
- AC_PATH_XTRA
- X_LIBS="$X_LIBS -lX11"
-
- if test "x$no_x" = "xyes"
- then
- AC_MSG_ERROR([X is required, but it was either disabled or not found.])
- fi
-
- save_LIBS="$LIBS"
- save_CFLAGS="$CFLAGS"
- CFLAGS="$CFLAGS $X_CFLAGS"
- LIBS="$LIBS $X_LIBS"
-
- AC_MSG_CHECKING([for XTHREADS in Xlib])
- AC_RUN_IFELSE(
- [AC_LANG_PROGRAM([[#include <X11/Xlib.h>]],
- [[return XInitThreads() == 0 ? 0 : 1;]])],
- [xthreads=no],
- [xthreads=yes],
- [xthreads=yes])
-
- AC_MSG_RESULT($xthreads)
-
- LIBS="$save_LIBS"
- CFLAGS="$save_CFLAGS"
-
- if test "x$xthreads" = "xyes"
- then
- X_CFLAGS="$X_CFLAGS -DXTHREADS"
- fi
-fi
+XORG_DEFAULT_OPTIONS
# Check damageext configuration, strip extra digits from package version to
# find the required protocol version
DAMAGEEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
AC_SUBST(DAMAGEEXT_VERSION)
-PKG_CHECK_MODULES(XDAMAGE, [damageproto >= $DAMAGEEXT_VERSION] xfixes fixesproto xextproto)
+PKG_CHECK_MODULES(XDAMAGE, [damageproto >= $DAMAGEEXT_VERSION] xfixes fixesproto xextproto x11)
AC_SUBST(XDAMAGE_CFLAGS)
-XORG_RELEASE_VERSION
-
AC_OUTPUT([Makefile
src/Makefile
xdamage.pc])