summaryrefslogtreecommitdiff
path: root/lib/libXi/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXi/configure.ac')
-rw-r--r--lib/libXi/configure.ac27
1 files changed, 20 insertions, 7 deletions
diff --git a/lib/libXi/configure.ac b/lib/libXi/configure.ac
index 6cef7160d..377dfe07e 100644
--- a/lib/libXi/configure.ac
+++ b/lib/libXi/configure.ac
@@ -1,27 +1,40 @@
-dnl $XdotOrg: lib/Xi/configure.ac,v 1.9 2005/12/15 00:24:30 kem Exp $
-dnl
dnl Process this file with autoconf to create configure.
AC_PREREQ([2.57])
-AC_INIT(libXi, 1.2.1, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXi)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_INIT(libXi, 1.3, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXi)
+AM_INIT_AUTOMAKE([dist-bzip2 foreign])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(src/config.h)
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
+AC_PROG_SED
+XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XI, xproto x11 xextproto xext inputproto >= 1.5)
+PKG_CHECK_MODULES(XI, [xproto >= 7.0.13] [x11 >= 1.2.99.1] [xextproto >= 7.0.3] [xext >= 1.0.99.1] [inputproto >= 1.9.99.902])
+XI_CFLAGS="$CWARNFLAGS $XI_CFLAGS"
AC_SUBST(XI_CFLAGS)
AC_SUBST(XI_LIBS)
+# Check for xmlto and asciidoc for man page conversion
+# (only needed by people building tarballs)
+AC_ARG_VAR([XMLTO], [Path to xmlto command])
+AC_PATH_PROG([XMLTO], [xmlto])
+AC_ARG_VAR([ASCIIDOC], [Path to asciidoc command])
+AC_PATH_PROG([ASCIIDOC], [asciidoc])
+AM_CONDITIONAL([HAVE_DOCTOOLS], [test "x$XMLTO" != "x" && test "x$ASCIIDOC" != "x"])
+if test "x$XMLTO" = "x" || test "x$ASCIIDOC" = "x"; then
+ AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
+fi
+
XORG_CHECK_MALLOC_ZERO
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
AC_OUTPUT([Makefile
src/Makefile