summaryrefslogtreecommitdiff
path: root/lib/libXrandr/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXrandr/configure.ac')
-rw-r--r--lib/libXrandr/configure.ac17
1 files changed, 9 insertions, 8 deletions
diff --git a/lib/libXrandr/configure.ac b/lib/libXrandr/configure.ac
index ad7dc67d8..0b18ee612 100644
--- a/lib/libXrandr/configure.ac
+++ b/lib/libXrandr/configure.ac
@@ -1,5 +1,5 @@
dnl
-dnl $Id: configure.ac,v 1.1 2006/11/25 17:37:37 matthieu Exp $
+dnl $Id: configure.ac,v 1.2 2009/05/02 15:20:43 matthieu Exp $
dnl
dnl Copyright © 2003 Keith Packard, Noah Levitt
dnl
@@ -32,34 +32,35 @@ dnl try to keep these the same. Note that the library has an extra
dnl digit in the version number to track changes which don't affect the
dnl protocol, so Xrandr version l.n.m corresponds to protocol version l.n
dnl
-AC_INIT(libXrandr, 1.1.2, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXrandr)
+AC_INIT(libXrandr, 1.3.0, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXrandr)
AC_CONFIG_AUX_DIR(.)
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
AM_CONFIG_HEADER(config.h)
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
-
-# Check for X
-PKG_CHECK_MODULES(X, x11)
-AC_SUBST(X_CFLAGS)
-AC_SUBST(X_LIBS)
+XORG_CWARNFLAGS
# Check randr configuration, strip extra digits from package version to
# find the required protocol version
RANDR_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
AC_SUBST(RANDR_VERSION)
-PKG_CHECK_MODULES(RANDR, randrproto >= $RANDR_VERSION xext xextproto xrender renderproto)
+PKG_CHECK_MODULES(RANDR, x11 randrproto >= $RANDR_VERSION xext xextproto xrender renderproto)
+RANDR_CFLAGS="$CWARNFLAGS $RANDR_CFLAGS"
AC_SUBST(RANDR_CFLAGS)
AC_SUBST(RANDR_LIBS)
XORG_CHECK_MALLOC_ZERO
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile
src/Makefile