summaryrefslogtreecommitdiff
path: root/lib/libXtst/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXtst/configure.ac')
-rw-r--r--lib/libXtst/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/libXtst/configure.ac b/lib/libXtst/configure.ac
index 1f2927f7e..5796d1f9d 100644
--- a/lib/libXtst/configure.ac
+++ b/lib/libXtst/configure.ac
@@ -48,6 +48,12 @@ XORG_CHECK_SGML_DOCTOOLS(1.8)
# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(XTST, x11 [xext >= 1.0.99.4] xi [recordproto >= 1.13.99.1] [xextproto >= 7.0.99.3] inputproto)
+# Check for _XEatDataWords function that may be patched into older Xlib release
+SAVE_LIBS="$LIBS"
+LIBS="$XTST_LIBS"
+AC_CHECK_FUNCS([_XEatDataWords])
+LIBS="$SAVE_LIBS"
+
# Determine if the source for man pages is available
# It may already be present (tarball) or can be generated using xmlto
AM_CONDITIONAL([INSTALL_MANPAGES],