summaryrefslogtreecommitdiff
path: root/lib/libXxf86dga/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXxf86dga/man/Makefile.am')
-rw-r--r--lib/libXxf86dga/man/Makefile.am87
1 files changed, 87 insertions, 0 deletions
diff --git a/lib/libXxf86dga/man/Makefile.am b/lib/libXxf86dga/man/Makefile.am
new file mode 100644
index 000000000..1da0432fd
--- /dev/null
+++ b/lib/libXxf86dga/man/Makefile.am
@@ -0,0 +1,87 @@
+# $Id: Makefile.am,v 1.1 2006/11/25 18:07:00 matthieu Exp $
+#
+# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation.
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+# IN NO EVENT SHALL THE OPEN GROUP BE LIABLE FOR ANY CLAIM, DAMAGES OR
+# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE.
+#
+# Except as contained in this notice, the name of the copyright holders shall
+# not be used in advertising or otherwise to promote the sale, use or
+# other dealings in this Software without prior written authorization
+# from the copyright holders.
+#
+
+libmandir = $(LIB_MAN_DIR)
+
+LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
+
+libman_PRE = XDGA.man
+
+BUILT_SOURCES = shadows.DONE
+
+EXTRA_DIST = $(libman_PRE)
+
+CLEANFILES = $(libman_DATA) $(BUILT_SOURCES)
+
+libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@) \
+ $(XDGA_shadows:=.@LIB_MAN_SUFFIX@)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's/__vendorversion__/"$(XORGRELSTRING)" "$(XORGMANNAME)"/' \
+ -e 's/__xconfigfile__/xorg.conf/g' \
+ -e 's/__xservername__/Xorg/g' \
+ -e 's/__appmansuffix__/$(APP_MAN_SUFFIX)/g' \
+ -e 's/__filemansuffix__/$(FILE_MAN_SUFFIX)/g'
+
+SUFFIXES = .$(LIB_MAN_SUFFIX) .man
+
+.man.$(LIB_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@
+
+# Generate man page shadow files (Replaces InstallManPageAliases from Imake)
+DGAFUNCS = XDGAQueryExtension \
+ XDGAQueryVersion \
+ XDGAQueryModes \
+ XDGASetMode \
+ XDGAOpenFramebuffer \
+ XDGACloseFramebuffer \
+ XDGASetViewport \
+ XDGAInstallColormap \
+ XDGACreateColormap \
+ XDGASelectInput \
+ XDGAFillRectangle \
+ XDGACopyArea \
+ XDGACopyTransparentArea \
+ XDGAGetViewportStatus \
+ XDGASync \
+ XDGASetClientVersion \
+ XDGAChangePixmapMode \
+ XDGAKeyEventToXKeyEvent
+
+XDGA_shadows = XF86DGA XFree86-DGA $(DGAFUNCS)
+
+shadows.DONE:
+ -rm -f $(XDGA_shadows:=.@LIB_MAN_SUFFIX@)
+ (for i in $(XDGA_shadows:=.@LIB_MAN_SUFFIX@) ; do \
+ echo .so man$(LIB_MAN_DIR_SUFFIX)/XDGA.$(LIB_MAN_SUFFIX) > $$i; \
+ done)