summaryrefslogtreecommitdiff
path: root/lib/mesa/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mesa/configure.ac')
-rw-r--r--lib/mesa/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/lib/mesa/configure.ac b/lib/mesa/configure.ac
index 8d70655eb..5cc47013f 100644
--- a/lib/mesa/configure.ac
+++ b/lib/mesa/configure.ac
@@ -159,7 +159,14 @@ else
fi
fi
-AM_CONDITIONAL(REGEN_SOURCES, test -n "$PYTHON2")
+dnl Avoid attempting to rebuild files with python and yacc
+AC_ARG_ENABLE([regen-sources],
+ [AS_HELP_STRING([--disable-regen-sources],
+ [disable regenerating source with python and yacc @<:@default=enabled@:>@])],
+ [regen_sources="$enableval"],
+ [regen_sources=yes])
+
+AM_CONDITIONAL(REGEN_SOURCES, test "x$regen_sources" = xyes)
AC_PROG_INSTALL