summaryrefslogtreecommitdiff
path: root/xserver/hw/xfree86/drivers/modesetting/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xserver/hw/xfree86/drivers/modesetting/Makefile.am')
-rw-r--r--xserver/hw/xfree86/drivers/modesetting/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/xserver/hw/xfree86/drivers/modesetting/Makefile.am b/xserver/hw/xfree86/drivers/modesetting/Makefile.am
index e0411ef51..961c57408 100644
--- a/xserver/hw/xfree86/drivers/modesetting/Makefile.am
+++ b/xserver/hw/xfree86/drivers/modesetting/Makefile.am
@@ -24,6 +24,8 @@
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+include $(top_srcdir)/manpages.am
+
AM_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS) $(LIBDRM_CFLAGS) $(UDEV_CFLAGS) $(CWARNFLAGS)
AM_CPPFLAGS = \
@@ -62,9 +64,3 @@ driverman_DATA = $(driverman_PRE:man=@DRIVER_MAN_SUFFIX@)
EXTRA_DIST = modesetting.man
CLEANFILES = $(driverman_DATA)
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-SUFFIXES = .$(DRIVER_MAN_SUFFIX) .man
-
-.man.$(DRIVER_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@