summaryrefslogtreecommitdiff
path: root/xserver/hw/xfree86/utils/ioport/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xserver/hw/xfree86/utils/ioport/Makefile.am')
-rw-r--r--xserver/hw/xfree86/utils/ioport/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/xserver/hw/xfree86/utils/ioport/Makefile.am b/xserver/hw/xfree86/utils/ioport/Makefile.am
index e96681bbf..6652c75c1 100644
--- a/xserver/hw/xfree86/utils/ioport/Makefile.am
+++ b/xserver/hw/xfree86/utils/ioport/Makefile.am
@@ -25,7 +25,7 @@
# or other dealings in this Software without prior written authorization
# of the copyright holder.
#
-
+if BUILD_IOPORT
bin_PROGRAMS = ioport
XFREE86_SRCDIR = $(top_srcdir)/hw/xfree86
@@ -33,7 +33,7 @@ DUMMYLIB_SRCDIR = $(XFREE86_SRCDIR)/dummylib
INCLUDES = $(XORG_INCS) -I$(DUMMYLIB_SRCDIR)
-ioport_CFLAGS = $(XORG_CFLAGS)
+ioport_CFLAGS = $(DIX_CFLAGS) $(XORG_CFLAGS)
ioport_LDADD = \
../../os-support/libxorgos.la \
../../dummylib/libdummy-nonserver.a \
@@ -56,3 +56,6 @@ install-exec-hook:
(cd $(DESTDIR)$(bindir); $(LN_S) ioport $$i)); \
done
+else
+all-local:
+endif