summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:36:56 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:36:56 -0500
commit5644e27cc492491b746ba59571b1b40d10909aa5 (patch)
tree58447d12dd5e1583c46ab65c552a377667aa93f4 /Makefile.am
parent22350f7bc7dec5d516989ace9d5ca89a033abb4b (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 176aeae..b15dd44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -78,3 +78,13 @@ SUFFIXES += .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog