summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-06-01 19:27:15 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-06-01 19:27:15 -0700
commit3a2473affe1e15d6e8d252db7ec5e22fd1683978 (patch)
tree023b0349e60706cf11213e67ce09c99c975c5cd8 /Makefile.am
parent6dcc9c8064baeb2f9d853309123cd9736809a4fd (diff)
Use _CONST_X_STRING to make libXt declare String as const char *
Clears 169 out of 240 -Wdiscarded-qualifiers warnings from gcc 7.3 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index def4d8b..4e44ade 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,8 @@
SUBDIRS=man
bin_PROGRAMS = bitmap bmtoa atobm
+AM_CPPFLAGS = -D_CONST_X_STRING
+
bitmap_CFLAGS = $(CWARNFLAGS) $(BITMAP_CFLAGS)
bitmap_LDADD = $(BITMAP_LIBS) $(MATH_LIBS)
bitmap_SOURCES = \