summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-08-09 16:30:19 -0400
committerGaetan Nadon <memsize@videotron.ca>2010-08-11 08:03:02 -0400
commit7c55725e4eaf2296d4ea047a155d0ec7bc4976fd (patch)
tree3b0ace5dfdf3dcbbd64b9c630da5580d573bf943 /Makefile.am
parent85b1eda6ac104850add5a98fc4caca7f59d7cb19 (diff)
config: simplify building of shadow man pages
Store the shadow files in git as any other man page. Move man pages to man dir and use the common makefile Local fix for bug 5628 in commit d8f719a352cd4d4ace60566b73a077175940a351 is not required as the problem has been fixed in util-macros d9062e4077ebfd0985baf8418f3d0f111b9ddbba Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 1 insertions, 30 deletions
diff --git a/Makefile.am b/Makefile.am
index 8b7dc93..9afde64 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS=man
bin_PROGRAMS = bitmap bmtoa atobm
# bitmap
@@ -53,12 +54,6 @@ atobm_LDADD = $(ATOBM_LDADD)
atobm_SOURCES = \
atobm.c
-# mans
-
-appman_PRE = \
- bitmap.man
-
-
# App default files (*.ad)
DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
@@ -102,29 +97,5 @@ dist_bitmap_DATA = \
Term \
Up
-APP_MAN_DIR_SUFFIX = $(APP_MAN_DIR:@mandir@/man%=%)
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@) \
- $(man_shadows:=.@APP_MAN_SUFFIX@)
-
-BUILT_SOURCES = shadows.DONE
-
-EXTRA_DIST += $(appman_PRE)
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA) $(BUILT_SOURCES)
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-
-man_shadows = atobm bmtoa
-shadows.DONE:
- -rm -f $(man_shadows:=.@APP_MAN_SUFFIX@)
- (for i in $(man_shadows:=.@APP_MAN_SUFFIX@) ; do \
- echo .so man$(APP_MAN_DIR_SUFFIX)/bitmap.$(APP_MAN_SUFFIX) > $$i; \
- done)