summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 11 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e5557e0..75cf4e2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,8 +37,18 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
+# Optional dependencies
+AC_ARG_WITH(xkb,
+ AS_HELP_STRING([--without-xkb],
+ [Disable use of XKB to sound bells (Default is with-xkb)]),
+ use_xkb="$withval", use_xkb="yes")
+if test x$use_xkb != xno ; then
+ XKBMODULE="xkbfile"
+ AC_DEFINE([XKB], 1, [Define to use XkbStdBell (libxkbfile)])
+fi
+
# Obtain compiler/linker options from dependencies
-PKG_CHECK_MODULES(EDITRES, [xaw7 x11 xt >= 1.0.99.1 xmu xproto >= 7.0.17])
+PKG_CHECK_MODULES(EDITRES, [xaw7 x11 xt >= 1.0.99.1 xmu xproto >= 7.0.17 ${XKBMODULE}])
PKG_CHECK_MODULES(APPDEFS, xt)
xt_appdefaultdir=`$PKG_CONFIG --variable=appdefaultdir xt`