summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2008-11-05 10:07:33 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2008-11-05 10:07:33 -0800
commit0ca983a6bac03489fb0d2ad158114a811eb276a2 (patch)
treeb730601c46334c7f29606d783638859e5c704a1e /configure.ac
parent8126d2b694f48cc8137be05705a125f7d02e7e12 (diff)
Add support for bzip2 compressed fonts if configured --with-bzip2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8775081..ae5436c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,16 @@ AC_PROG_INSTALL
AC_CHECK_LIB(z, gzopen, [],
[AC_MSG_ERROR([zlib is required, but was not found.])])
+AC_ARG_WITH(bzip2,
+ AS_HELP_STRING([--with-bzip2],
+ [Support bzip2 compressed bitmap fonts]),
+ [], [with_bzip2=no])
+if test "x$with_bzip2" = xyes; then
+ AC_CHECK_LIB(bz2, BZ2_bzopen, [],
+ AC_MSG_ERROR([*** libbz2 is required for bzip2 support]))
+ AC_DEFINE(X_BZIP2_FONT_COMPRESSION,1,[Support bzip2 for bitmap fonts])
+fi
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(MKFONTSCALE, fontenc freetype2)
AC_SUBST(MKFONTSCALE_CFLAGS)