summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-11-07 18:39:58 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-11-07 18:39:58 -0800
commitaa27f60ff70230990bd7351bbfda3d38f95afe3b (patch)
tree6cc0bbaf53246ae38f69fa73ed7ad48745993c3c /Makefile.am
parentfd251f039f74f2ef8ef8a019566eebf9d22be098 (diff)
Add hooks for checking code with lint/sparse/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f33a11a..45a089d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -63,3 +63,11 @@ sessreg.$(APP_MAN_SUFFIX): filenames.sed
filenames.sed: filenames.sed.c
$(CPP) $(DEFS) $(srcdir)/filenames.sed.c | grep 's\|__' > $@
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(sessreg_SOURCES)
+endif LINT