summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEd Schouten <ed@80386.nl>2011-06-24 15:46:43 +0200
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-06-24 20:56:32 -0700
commit301cbd433bb698147e05e7dbfb4de2ce2e0e9cbb (patch)
tree0fe15893475a400eb897104e069b53b6c390acfc /configure.ac
parenteb6eb771ff9f53c56bd60f28c5598eee9e2fb9b2 (diff)
Use Autoconf to check for utmp field existence.
Don't use the quirky SYSV and __QNX__ definitions to determine whether the utmp fields exist. Signed-off-by: Ed Schouten <ed@80386.nl> Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c7e5e90..be90cf3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,11 @@ XORG_WITH_LINT
AC_CHECK_HEADERS([lastlog.h utmp.h utmpx.h sys/param.h])
# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_MEMBERS([
+ struct utmp.ut_host,
+ struct utmp.ut_id,
+ struct utmp.ut_pid,
+ struct utmp.ut_type], [], [], [#include <utmp.h>])
AC_CHECK_MEMBERS([struct utmpx.ut_syslen], [], [], [#include <utmpx.h>])
# Checks for library functions.