summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-01-19 11:20:21 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-01-21 08:22:23 -0500
commit5a886e2fc5f4b3f062a20f66ee68bad4a0b98ad1 (patch)
tree0da928efbc186224a72bbd8c71cc3bfddd79d088 /configure.ac
parent4eaaa6a84a52b7c60df964102f0fb8d860b00308 (diff)
config: use AC_CHECK_MEMBERS rather than AC_CHECK_MEMBER
Let Autoconf do the work of setting up the #define in config.h. Apply and comment standard sections layout. Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f3c9f4e..c7e5e90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,17 +42,14 @@ XORG_WITH_LINT
# Checks for header files.
AC_CHECK_HEADERS([lastlog.h utmp.h utmpx.h sys/param.h])
-AC_CHECK_MEMBER([struct utmpx.ut_syslen],
- HAVE_SYSLEN=1,
- HAVE_SYSLEN=0,
- [#include <utmpx.h>])
-AC_DEFINE_UNQUOTED(HAVE_UTMPX_UT_SYSLEN,$HAVE_SYSLEN,
- [utmpx structure includes ut_syslen field])
# Checks for typedefs, structures, and compiler characteristics.
+AC_CHECK_MEMBERS([struct utmpx.ut_syslen], [], [], [#include <utmpx.h>])
+
+# Checks for library functions.
AC_CHECK_FUNCS([updwtmpx utmpxname])
-# Checks for pkg-config packages
+# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(SESSREG, xproto)
AC_CONFIG_FILES([