summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-12-02 14:45:19 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-12-02 14:45:19 -0800
commit98316f44c03edaa55bf75c4ba2b3b9e3ec16efc6 (patch)
tree74d66a0a2a7c9cb83b3fd7ac7831a14ccbe55265 /configure.ac
parentce1fc38396864c89110339601398678b995676aa (diff)
configure: pass noyywrap to AC_PROG_LEX if using autoconf 2.70 or later
Raises minimum autoconf version from 2.60 to 2.64 for m4_version_prereq Clears autoconf warning: configure.ac:47: warning: AC_PROG_LEX without either yywrap or noyywrap is obsolete ./lib/autoconf/programs.m4:743: _AC_PROG_LEX is expanded from... ./lib/autoconf/programs.m4:736: AC_PROG_LEX is expanded from... configure.ac:47: the top level Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 692dc31..471dec7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@ dnl
dnl Process this file with autoconf to create configure.
# Initialize Autoconf
-AC_PREREQ([2.60])
+AC_PREREQ([2.64])
AC_INIT([twm], [1.0.12],
[https://gitlab.freedesktop.org/xorg/app/twm/issues], [twm])
AC_CONFIG_SRCDIR([Makefile.am])
@@ -44,7 +44,7 @@ if test ! -f "$srcdir/gram.c"; then
AC_MSG_ERROR([yacc not found - unable to compile gram.y])
fi
fi
-AC_PROG_LEX
+m4_version_prereq([2.70], [AC_PROG_LEX(noyywrap)], [AC_PROG_LEX])
AC_CHECK_FUNCS([mkstemp])