summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-16 17:17:41 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-16 17:17:41 -0700
commit266da0b9c176cf0dc615005bb0ad4aa585892bd8 (patch)
treef8e424caa32443c7177303c40d835f30e9ce429a /configure.ac
parent9851abff574fe041f4e3f45b39c61d943e3a7f86 (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 24e7896..d877e8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,16 +25,17 @@ AC_INIT(x11perf,[1.5], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg]
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
AC_PATH_PROG(SED,sed)
if [[ -z $SED ]] ; then
@@ -45,7 +46,6 @@ AC_TYPE_SIGNAL
# Checks for pkg-config packages
PKG_CHECK_MODULES(X11PERF, x11 xmuu)
-X11PERF_CFLAGS="$CWARNFLAGS $X11PERF_CFLAGS"
AC_SUBST(X11PERF_CFLAGS)
AC_SUBST(X11PERF_LIBS)
@@ -83,8 +83,4 @@ yes)
;;
esac
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])