summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-06-01 19:39:07 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-06-01 19:39:07 -0700
commite18a25f27313d90ec8da4057b8413b6937bee1c2 (patch)
tree74d3698f3abdabf152f0aa64eef8eb303faa3a06 /Makefile.am
parent2c0ba1ba92fdf393f30ffab0667cf507ecae09b0 (diff)
Use _CONST_X_STRING to make libXt declare String as const char *
Clears up 20 of 35 gcc -Wdiscarded-qualifiers warnings from gcc 7.3 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 898a7ea..c55f53e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@
SUBDIRS = man
bin_PROGRAMS = xbiff
-AM_CFLAGS = $(CWARNFLAGS) $(XBIFF_CFLAGS) -D_BSD_SOURCE
+AM_CFLAGS = $(CWARNFLAGS) $(XBIFF_CFLAGS) -D_BSD_SOURCE -D_CONST_X_STRING
xbiff_LDADD = $(XBIFF_LIBS)
xbiff_SOURCES = \