summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-12-20 12:21:37 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-12-20 19:14:25 -0800
commit7862d8d80e8612b3e7285ce2fe3ec901fda05fe6 (patch)
tree2519ad00c25808d6a7fd6165e655dac6b47f38c7 /configure.ac
parentc3d0f59af3626b73c32e8e03a41d6a712909c7af (diff)
configure: Use AC_SYS_LARGEFILE to enable large file support
Also adds include of "config.h" before any other header files are included, to avoid mismatch of _FILE_OFFSET_BITS when processing other header files. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 52ddb3d..dd8cbff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,6 +43,9 @@ PKG_CHECK_MODULES(XBIFF, xaw7 xmu xbitmaps xext x11)
# Checks for headers
AC_CHECK_HEADERS([paths.h])
+# Checks for typedefs, structures, and compiler characteristics.
+AC_SYS_LARGEFILE
+
# Allow builder to set path to look for mailboxes
AC_MSG_CHECKING([for mailbox directory])
AC_ARG_WITH([mailbox-directory],