summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index fb790a7..5891c6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,8 +21,14 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT(xbiff, [1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xbiff)
+AC_INIT([xbiff], [1.0.2],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xbiff])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
@@ -32,8 +38,7 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AM_CONFIG_HEADER(config.h)
-
+# Checks for pkg-config packages
PKG_CHECK_MODULES(XBIFF, xaw7 xmu xbitmaps xext x11)
AC_OUTPUT([Makefile])