summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-08-06 15:36:57 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-08-06 15:36:57 -0700
commit0c458e28ff7a3f85c0041ac0f01791853c6bdf28 (patch)
tree9dc2db7a745397ef04a477b3dead90cc59790ede /Makefile.am
parentc94628bef06ea76be371eb0dc8b60bdf0e0009e9 (diff)
Replace static changelog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 48c056c..b3169da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -51,6 +51,7 @@ SUFFIXES = .ad
appdefault_DATA = $(APPDEFAULTFILES)
EXTRA_DIST = \
+ ChangeLog \
$(APPDEFAULTFILES:%=%.ad) \
clmask.bit \
clock.bit
@@ -64,6 +65,15 @@ appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
EXTRA_DIST += $(appman_PRE)
CLEANFILES += $(appman_DATA)
+MAINTAINERCLEANFILES=ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+
SED = sed
# Strings to replace in man pages