summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-01 17:55:48 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-01 17:55:48 +0000
commit80d8b6affb2ee823cf18a368ab33535cb1cf1721 (patch)
tree3266cfd49fbf7a71ce36ce2021ce092291a45293 /Makefile.am
parentca43036f8cdd456ebff29860fd514248b3699bcf (diff)
Build system for xclock
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am54
1 files changed, 54 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..42a74e0
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,54 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+bin_PROGRAMS = xclock
+
+xclock_CFLAGS = $(DEP_CFLAGS)
+xclock_LDADD = $(DEP_LIBS)
+
+xclock_SOURCES = \
+ Clock.c \
+ Clock.h \
+ ClockP.h \
+ xclock.c
+
+dist_man_MANS = \
+ xclock.man
+
+# App default files (*.ad)
+
+appdefaultdir = $(sysconfdir)/X11/app-defaults
+
+
+APPDEFAULTFILES = \
+ XClk-col \
+ XClock
+
+
+$(APPDEFAULTFILES): %: %.ad
+ cp $< $@
+
+appdefault_DATA = $(APPDEFAULTFILES)
+
+EXTRA_DIST = $(foreach FILE, $(APPDEFAULTFILES), $(FILE).ad)
+
+CLEANFILES = $(APPDEFAULTFILES)
+