summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2011-08-23 19:05:20 -0500
committerYaakov Selkowitz <yselkowitz@users.sourceforge.net>2011-08-24 23:10:57 -0500
commit45e936174e39637c09cd10c0a5c6f8752ee2d709 (patch)
tree1ac68c1e8f13063578f75c70263f2caa84efceab /configure.ac
parent27e10658010d314b40dfc9403a92864b26a9d576 (diff)
Use AM_ICONV
AC_SEARCH_LIBS does not detect GNU libiconv because its symbols are exported in the "libiconv" namespace instead of "iconv". The AM_ICONV macro correctly detects both glibc and GNU libiconv, defines HAVE_ICONV, ICONV_CONST, and LIBICONV depending on the system. The config.rpath file is required by this macro. This adds a dependency on the aclocal macros from gettext (gettext-devel in some distros) when building from git, but not when building from a tarball. Signed-off-by: Yaakov Selkowitz <yselkowitz@users.sourceforge.net> Reviewed-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8baae9e..19d1264 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,11 +41,11 @@ AC_CONFIG_HEADERS([config.h])
AC_CHECK_FUNCS([strlcpy getpid])
-AC_SEARCH_LIBS([iconv], [iconv],
- [AC_DEFINE(HAVE_ICONV, 1, [Define to 1 if iconv() is available.])])
+AM_ICONV
dnl Required dependencies
PKG_CHECK_MODULES(XCLOCK, xaw7 xmu x11)
+XCLOCK_LIBS="$XCLOCK_LIBS $LIBICONV"
dnl Optional dependencies
AC_ARG_WITH(xft, AS_HELP_STRING([--with-xft],[Use Xft2 and Xrender for rendering (Default is YES)]),use_xft="$withval",use_xft="try")