summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-16 16:20:14 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-16 16:20:14 -0700
commit7c88f82a86249eac513643c2a5f4dceb86cb754d (patch)
treefd773190f178c0185056f8200931874f6cced8b1 /configure.ac
parentcdec3cdf9e45c8232ffba8f8ad51d2880d8e6da9 (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 5 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 5b64c31..6b189a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,9 +25,10 @@ AC_INIT(xdriinfo, [1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=x
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
@@ -36,11 +37,10 @@ AC_PROG_INSTALL
AC_TYPE_SIGNAL
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
PKG_CHECK_MODULES(XDRIINFO, x11 glproto)
-XDRIINFO_CFLAGS="$CWARNFLAGS $XDRIINFO_CFLAGS"
AC_SUBST(XDRIINFO_CFLAGS)
AC_SUBST(XDRIINFO_LIBS)
@@ -49,9 +49,4 @@ AC_SEARCH_LIBS([glXGetProcAddressARB], [GL], [],
AC_MSG_FAILURE([cannot find GL library - make sure Mesa or other OpenGL package is installed]),
[$XDRIINFO_LIBS])
-
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])