summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2008-03-11 22:28:04 -0300
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2008-07-02 19:07:29 -0300
commit60643e8f0dcd86e65400160c0a6e264e7a2a081c (patch)
treefa0fa737912ea226dcee3b41b902b00b5c25fba2 /Makefile.am
parentee636f8565931f8d897b6c8c07eb08d41695778c (diff)
Support multiple make jobs.
Minor patch to avoid requiring xedit to have some special rule in a buildsystem that defaults to something like "make -j 16".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e58c759..39d8b0b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -102,7 +102,7 @@ libre_a_SOURCES = \
#
# xedit
#
-
+xedit_DEPENDENCIES = liblisp.a libmp.a libre.a
xedit_CFLAGS = $(PKGDEPS_CFLAGS) -I$(top_srcdir)/lisp/re -D_BSD_SOURCE -DXEDIT
xedit_LDADD = -L. -lre -llisp -lmp $(PKGDEPS_LIBS) -lm
@@ -138,6 +138,7 @@ xedit_SOURCES += \
endif
# lisp/lsp
+lisp_lsp_DEPENDENCIES = liblisp.a libre.a libmp.a
lisp_lsp_CFLAGS = -I$(top_srcdir)/lisp/re -I$(top_srcdir)/lisp/mp -DLISP -DLISPDIR=\"@LISPDIR@\" -D_BSD_SOURCE
lisp_lsp_LDADD = -L. -llisp -lre -lmp -lm
lisp_lsp_SOURCES = \
@@ -153,6 +154,7 @@ lisp_lsp_SOURCES += strcasecmp.c
endif
# re/tests
+lisp_re_tests_DEPENDENCIES = libre.a
lisp_re_tests_CFLAGS = -I$(top_srcdir)/lisp/re -D_BSD_SOURCE
lisp_re_tests_LDADD = -L. -lre
lisp_re_tests_SOURCES = lisp/re/tests.c