summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2024-04-21 15:46:52 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2024-04-21 15:46:52 -0700
commit8fa3682c14fc40a06f3af9a462301f39739a26bd (patch)
tree9ccd742df79644879a098874cd90549663e528cd /Makefile.am
parent75ad621cfcf3c2591b7b9602bc0934d445153c6a (diff)
Assume all target platforms have strcasecmp() now
It's a standard part of Unix98/SUSv2 and later Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Part-of: <https://gitlab.freedesktop.org/xorg/app/xedit/-/merge_requests/10>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 0 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index fa30eaf..942cdb5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -125,10 +125,6 @@ if NEED_REALPATH
xedit_SOURCES += realpath.c
endif
-if NEED_STRCASECMP
-xedit_SOURCES += strcasecmp.c
-endif
-
# lisp/lsp
lisp_lsp_DEPENDENCIES = liblisp.a libre.a libmp.a
lisp_lsp_CFLAGS = $(CWARNFLAGS) -I$(top_srcdir)/lisp/re -I$(top_srcdir)/lisp/mp -DLISP -DLISPDIR=\"@LISPDIR@\" -D_BSD_SOURCE
@@ -141,10 +137,6 @@ if NEED_REALPATH
lisp_lsp_SOURCES += realpath.c
endif
-if NEED_STRCASECMP
-lisp_lsp_SOURCES += strcasecmp.c
-endif
-
# re/tests
lisp_re_tests_DEPENDENCIES = libre.a
lisp_re_tests_CFLAGS = $(CWARNFLAGS) -I$(top_srcdir)/lisp/re -D_BSD_SOURCE