summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:12 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:37:12 -0500
commit946b5b745d9d326799a23f7210b799e1b690643d (patch)
treec230cf06018ac86aca82d07dc007a2480de7c427 /Makefile.am
parentdd27b05c49b6e747203c83a96ca812993b2a2def (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e2acfbb..f698010 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -233,3 +233,13 @@ SUFFIXES += .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog