summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-11-08 23:34:03 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-11-08 23:38:59 -0800
commitb24dce8f95cbed1a91a989a783eb1fdd36335bf1 (patch)
tree88cd16651210e0e2cce43a859a9cab12fea16067 /configure.ac
parent34ea83ac16ce3bc55aedd9d8e73e3d4a04bafdcc (diff)
config: Remove unnecessary calls from configure.ac
AC_PROG_CC & AC_PROG_INSTALL are provided by XORG_DEFAULT_OPTIONS now PKG_CONFIG_MODULES handles AC_SUBST of the CFLAGS & LIBS variables Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 0 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index d98b698..d4c8ed5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,21 +34,13 @@ m4_ifndef([XORG_MACROS_VERSION],
XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AC_PROG_CC
-AC_PROG_INSTALL
-
-
# Checks for pkg-config packages
PKG_CHECK_MODULES(XEYES, x11 xt xext xmu)
-AC_SUBST(XEYES_CFLAGS)
-AC_SUBST(XEYES_LIBS)
dnl Optional dependencies
AC_ARG_WITH(xrender, AC_HELP_STRING([--with-xrender],[Use Xrender for rendering (Default is YES)]),use_xrender="$withval",use_xrender="try")
if test x$use_xrender != xno ; then
PKG_CHECK_MODULES(XRENDER, [xrender >= 0.4])
- XEYES_CFLAGS="$XEYES_CFLAGS $XRENDER_CFLAGS"
- XEYES_LIBS="$XEYES_LIBS $XRENDER_LIBS"
AC_DEFINE([XRENDER],1,[Define to use X Render Extension])
fi