summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 031692e..3171978 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,12 @@ if test x$use_xrender != xno ; then
AC_DEFINE([XRENDER],1,[Define to use X Render Extension])
fi
+AC_ARG_WITH(present, AS_HELP_STRING([--with-present],[Use Present for updates (Default is AUTO)]),use_present="$withval",use_present="try")
+if test x$use_present != xno ; then
+ PKG_CHECK_MODULES(PRESENT, [x11-xcb xcb-present >= 1.9 xcb-xfixes xcb-damage])
+ AC_DEFINE([PRESENT],1,[Define to use X Present Extension])
+fi
+
AC_CONFIG_FILES([
Makefile
man/Makefile])