summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-12 20:50:14 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-12 20:50:14 -0700
commitb21606e278defaebc458519d1d65d3acfe6ef8a1 (patch)
tree84309ecd7b3075d4a126acb16d88c55889b9f72d /configure.ac
parent3b900ab3755f6b2b7013297cb3e01735d83cbdcb (diff)
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 1e26248..f8a3801 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,25 +26,21 @@ AC_INIT(xf86dga,[1.0.2], [https://bugs.freedesktop.org/enter_bug.cgi?product=xor
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
AC_PROG_CC
AC_PROG_INSTALL
-XORG_CWARNFLAGS
+XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
PKG_CHECK_MODULES(XF86DGA, x11 xxf86dga)
-XF86DGA_CFLAGS="$CWARNFLAGS $XF86DGA_CFLAGS"
AC_SUBST(XF86DGA_CFLAGS)
AC_SUBST(XF86DGA_LIBS)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile])