summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-01-19 10:06:56 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-01-19 10:06:56 -0500
commitb7cb4106bca08b2ffebf7494dcc547c974cd2bdb (patch)
tree1aa009bdc4b3fd6657ee0bc06c2cea145690a5fc /man/Makefile.am
parentd2f47149264cd2050f5c442cd8765998a4f936c4 (diff)
config: move man pages into their own directory
Use services provided by XORG_MANPAGE_SECTIONS. Use standard Makefile for man pages. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..7110bc5
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,12 @@
+
+appmandir = $(APP_MAN_DIR)
+appman_PRE = dga.man
+appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+.man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@