summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/Makefile.am b/Makefile.am
index 60f089a..2152b78 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
+SUBDIRS = man
bin_PROGRAMS = xfd
AM_CFLAGS = $(XFD_CFLAGS) $(CWARNFLAGS) -DXRENDER -D_BSD_SOURCE
@@ -32,9 +33,6 @@ xfd_SOURCES = \
gridP.h \
xfd.c
-appman_PRE = \
- xfd.man
-
# App default files
DISTCHECK_CONFIGURE_FLAGS = --with-appdefaultdir=\$${datadir}/X11/app-defaults
@@ -43,22 +41,7 @@ appdefaultdir = @appdefaultdir@
dist_appdefault_DATA = \
app-defaults/Xfd
-
-
-appmandir = $(APP_MAN_DIR)
-
-appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
-
-EXTRA_DIST = $(appman_PRE)
MAINTAINERCLEANFILES = ChangeLog INSTALL
-CLEANFILES = $(appman_DATA)
-
-SUFFIXES = .$(APP_MAN_SUFFIX) .man
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-.man.$(APP_MAN_SUFFIX):
- $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
-
.PHONY: ChangeLog INSTALL
@@ -76,5 +59,5 @@ noinst_DATA = xfd.po
xfd.po: $(xfd_SOURCES:%=$(srcdir)/%)
$(AM_V_GEN)xgettext -d xfd -n $(xfd_SOURCES:%=$(srcdir)/%)
-CLEANFILES += xfd.po
+CLEANFILES = xfd.po
endif