summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-09 13:19:21 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-09 13:19:21 -0800
commitf286ef347dc9e87c6d5b5b8bce22afdeb82af4ed (patch)
treec04f47f0e67b8456283e87e3c7b9fb0dce6449de /Makefile.am
parent57f670195bb1854edbea97b672ae966343965bb7 (diff)
Use gettext() to localize messages if available
Originally fixed for Solaris in August 2000 by Jay Hobson under Sun bug 4256527 "Internationalize xfontsel" Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e62fd49..62e51c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,3 +53,14 @@ ChangeLog:
dist-hook: ChangeLog INSTALL
EXTRA_DIST = README.md
+
+if USE_GETTEXT
+AM_CPPFLAGS = -DLOCALEDIR='"$(LOCALEDIR)"'
+
+noinst_DATA = xfontsel.po
+
+xfontsel.po: $(xfontsel_SOURCES:%=$(srcdir)/%)
+ $(AM_V_GEN)xgettext -d xfontsel -c -n $(xfontsel_SOURCES:%=$(srcdir)/%)
+
+CLEANFILES = xfontsel.po
+endif